FAQ Lock-On

Bugs, problèmes d'installation, de patch, optimisation
Avatar de l’utilisateur

Topic author
Kovy
Chef de patrouille
Chef de patrouille
Messages : 4723
Inscription : août 2001
Localisation : Paris
Contact :

FAQ Lock-On

Message #1 par Kovy » 03 déc. 2003, 22:32

Crash, freeze, retour windows, probleme de CD :



Q : Je suis sous windows 98se et lorsque je lance le jeu, la page de choix /simulation/entrainement/option/ etc.....est blanche et je ne vois pas les cases a cocher. quand peniblement j'arrive a cocher au pif une case pour voler il y'a plantage et retour sur le bureau windows ou freeze .

R : lock-on a des problemes avec win98.

La première chose à faire est d'installer le patch 1.01 FR (si vous avez une version française)

Si les problèmes persistent, essayer ces petites astuces:

Il apparait que windows 98 ne parvient pas à gérer plusieurs scene différentes...
Une solution simple consiste donc à renommer les scènes que vous n'utilisez pas pour que windows n'essaie pas de les charger.

Si par exemple vous voulez utiliser la scène "medium",
allez dans le dossier \Lock On\Bazar\Terrain\Scenes\
et renommez les scenes "high" et "low" (high-off et low-off par exemple)

Autres solution :

1. Allez dans le dossier d'installation de lock-on. Dans le sous-dossier
Bazar\Terrain\Scenes . sauvegardez les fichiers High.scn et Medium.scn

2. remplacez ces 2 fichiers par ceux de la démo : http://magonline.free.fr/lofix98.zip

3. démarrez lomac et dans les options graphiques, réglez scene sur low (bas)

Autre truc qui peut aider, réglez manuellement la taille de la mémoire virtuelle sur 2000 mo :

- clic droit sur "poste de travail"
- propriétés
- onglet performances
- regler la mémoire virtuelle mini sur 0 et maxi sur 2000

***********************************************

Q : Quand je lance Lock On, le CD n'est pas reconnu et le jeu refuse de démarrer.

R : C'est à cause des disques virtuels installés par certains logiciels. Appuyez sur la touche "maj" en lançant le jeu.

OU

Verifiez si le lecteur de cd rom IDE est configure en maitre.
Desactivez dans l onglet "Demarrage" (atteignables par "Demarrer" "Executer" et tapez msconfig) les utilitaires lies a votre logiciel de gravure (Clone Cd...) ainsi que les detecteurs de disques lies a votre carte son ou aux lecteurs Iomega.
Desactivez le Service COM de gravage des CD IMAPI (panneau de configuration, outils d administration, services)
Installez le patch SafeDisc pour Windows XP
http://www.microsoft.com/downloads/details...CE-1DF707D7A2E9
Installez le patch SafeDisc produit par Macrovision
http://www.macrovision.com/products/safedisc/downloads.shtml
Verifiez sur le site internet des constructeurs de vos lecteurs qu une mise a jour de firmware est disponible


***********************************************

Q : j'ai une machine haut de gamme (geforce FX, radeon 9xxx...) et lock-on fait planter mon ordinateur (reboot).

R : N'overclockez pas votre carte graphique ou votre processeur. Les effets de pixel shader utilisés dans lock-on n'aiment vraiment pas l'overclocking !!!

- Pour les ATI 9xxx, repassez en catalyst 3.7, ils sont beaucoup plus stables.

- Autre solution, installez les drivers omega :
drivers 3.9 omega (cartes ATI)
drivers 45.23 omega (cartes nvidia)

- Pour les Geforce FX5xxx, il semble que le jeu devienne instable au dessus de 1024*768, restez en 1024*768 si vous avez des reboots sauvages.

Si toutefois vous souhaitez utuiliser une autre résolution, ouvrer le fichier
\lock on\config\graphics.cfg avec un editeur de text (notepad)
et réglez manuelment toutes les résolutions sur une valeur identique :

DisplayMode
{
resolution = {1280, 1024};
bpp = 32;
fullscreen = 1;
aspect = 1.333333373;
Interface
{
resolution = {1280, 1024};
bpp = 32;
fullscreen = 1;
}
Simulation
{
resolution = {1280, 1024};
bpp = 32;
fullscreen = 1;
aspect = 1.333333373;
}

Cette manipe (tout passer en 1280 x 1024) permettrait aux geforces FX de ne plus planter pour les résolutions supérieures à 1024x768... car une fois le jeu lancé, il n'y aura plus de changement de resolution...

- Pour ATI et NVidia, les cartes AGP x8 sont manifestement souvent sources de problemes...essayez de passer en AGP x4 (réglage dans le bios) pour voir si cela n'améliore pas la stabilité. (mrci à Nicoleon)

**********************************************

- Q : j'essaie de lancer le jeu pour la première fois et celui ci se bloque sur la page d'acceuil. Tous les boutons de l'interface sont inactif.
- R : Lorsque vous lancez lock-on pour la première fois, il essaie de se connecter à internet. Si votre firewall est activé, ce dernier bloque lock-on.
Vérifiez que lock-on est bien autorisé à accéder à internet dans les paramètres de votre firewall ou désactivez votre firewall.
Image

Rafale News : le blog du rafale
:cheer: Rafale ! Rafale ! Rafale ! :cheer:
Avatar de l’utilisateur

Topic author
Kovy
Chef de patrouille
Chef de patrouille
Messages : 4723
Inscription : août 2001
Localisation : Paris
Contact :

Message #2 par Kovy » 03 déc. 2003, 22:34

Manuel :

Q : j'ai acheté une version française et je ne trouve pas le manuel sur le CD

R : Il y a un manuel papier basique d'une cinquantaine de page mais le manuel complet en pdf a été oublié sur les CD de la version française. il devrait être téléchargeable bientot.

le manuel pdf normal en Français est dispo chez ubisoft (traduit par France Simulation)

Un pdf spécial impression en englais (schémas lisibles, pas de fond bleu) est dispo ici

le manuel pdf normal en anglais est dispo ici
Image



Rafale News : le blog du rafale

:cheer: Rafale ! Rafale ! Rafale ! :cheer:
Avatar de l’utilisateur

Topic author
Kovy
Chef de patrouille
Chef de patrouille
Messages : 4723
Inscription : août 2001
Localisation : Paris
Contact :

Message #3 par Kovy » 03 déc. 2003, 22:43

Graphisme, écran bleu, frame rate, Disparition de textures

Q : Mon frame rate est catastrophique lorsque je vole avec la couche nuageuse, est-il possible d'améliorer le frame rate avec la couche ?

R : la couche nuageuse "overcast" provoque de sérieuses baisses de frame rate sur les cartes de la génération geforce 4 (et antérieure).
des textures plus petites sont disponibles pour améliorer le frame rate avec la couche disponible ici (low overcast_v3)
faites une sauvegarde de votre dossier "\Bazar\Effects\OVERCAST" original et remplacez le par celui que vous venez de télécharger

*******************************************

Q : Dans le jeu, mon écran devient bleu, que faire ?

R : c'est un problème lié aux cartes graphiques qui ne gèrent pas les effets direct X 8 (geforce 2 et toutes les geforce MX par exemple)
Il faut désactiver tous les effets dans les options graphique du jeu.

*******************************************

Q : J'ai une ATI 9xxx, Les textures s'affichent puis disparaissent indéfiniment, du coup c'est injouable, y a t-il une solution ?

R : Utilisez les drivers ATI catalyst 3.7 ou les drivers omega 3.9

[url=http://www.infos-du-net.com/redirect.php?[url]http://www2.ati.com/drivers/wxp-w2k-catalyst-7-93-030812a1-010735c-efg.exe]catalyst[/url] 3.7 pour windows 2000 / XP[/url]
[url=http://www.infos-du-net.com/redirect.php?[url]http://www2.ati.com/drivers/wme-catalyst-7-93-030812a1-010735c-efg.exe]catalyst[/url] 3.7 pour windows 98 / me[/url]

*******************************************

Q : les textures du jeu sont corrompues.

R : il se peut que ce problème soit du à l'overclocking de la carte graphique ou à un timing de la mémoire vive trop aggressif. Si vous avez modifié les timings de votre RAM dans le bios, ramenez les à des valeurs plus raisonables

Dans les options graphiques de lomac, essayez de désactiver les ombres portées (baissez le reglage des ombres d'un cran)
Image



Rafale News : le blog du rafale

:cheer: Rafale ! Rafale ! Rafale ! :cheer:
Avatar de l’utilisateur

Topic author
Kovy
Chef de patrouille
Chef de patrouille
Messages : 4723
Inscription : août 2001
Localisation : Paris
Contact :

Message #4 par Kovy » 04 déc. 2003, 11:48

Joysticks :

Q : Il m'est impossible de modifier les axes assignés par défaut dans le jeu ou de modifier les touches du clavier, comment faire ?

R : Allez dans le dossier config de lock-on et vérifiez que aucun fichier n'est en lecture seule (clic droit > propriétés)
Allez aussi dans le dossier input de lock-on et vérifiez que aucun fichier n'est en lecture seule (clic droit > propriétés)

******************************************

Q : Le palonier de mon joystick ne marche pas, comment faire ?

R :
Allez dans le menu option puis input (ou équivalent en français)
choisir axe -> puis rudder-> appuyer sur "change" -> et mettre rotator2
mettre aussi un peu de "dead zone". (voir image ci dessous)

Q : La manette des gaz de mon joystick ne marche pas, ou un seul reacteur fonctionne, comment faire ?

R :
Allez dans le menu option puis input (ou équivalent en français)
choisir axe -> puis supprimez l'axe de la manette des gaz gauche.
sélectionné la manette des gaz "générale"> appuyer sur "change" -> et mettre AXE 2 pour l'axe moteur (voir image ci dessous)

Image

*******************************************

Q : j'ai un joystick microsoft force feedback 2 et je n'ai pas de retour au centre, comment faire ?

R : C'est un bug qui est corrigé avec le patch 1.01

*******************************************

Q : J'ai plusieurs joysticks connectés à mon ordinateur et je constate des mouvements erratiques de mon avion dans lock on.

R : si vous avez plusieurs Joystick de connectés, vérifiez impérativement qu'un AXE est mappé à un SEUL joystick car Lock On asssigne les axes X et Y a tous les joysticks qu'il trouve

Cela vous enlevera le comportement eratique de l'avion sur l'axe Y et les mouvements parasites.
Image



Rafale News : le blog du rafale

:cheer: Rafale ! Rafale ! Rafale ! :cheer:
Avatar de l’utilisateur

Topic author
Kovy
Chef de patrouille
Chef de patrouille
Messages : 4723
Inscription : août 2001
Localisation : Paris
Contact :

Message #5 par Kovy » 04 déc. 2003, 15:55

Réseau :

Q : Je constate des énormes lag en réseau comment y remédier

R : un problème de timing sur les chipset nforce et nforce 2, peut provoquer des gros lags vis à vis des autres joueurs utilisant un chipset différent.

La première chose à faire est d'installer les derniers drivers nforce2 (actuellement les 3.13) ici pour win2000/XP
ou là pour win 98/Me

Assurez vous également que votre FSB et votre memoire vive fonctionne en mode synchrone (à la meme fréquence). Pour cela, vous devez aller dans le bios de votre ordinateur pour régler la fréquence de la mémoire vive.

***********************************

Q : dans une partie réseau, j'étais client et je n'ai pas pu ravitailler en vol, comment faire ?

R : Le ravitaillement en vol en réseau est possible normalement pour le host de la partie. Pour les clients, il est encore un peu buggé : les clients ne voient les paniers (ou la perche) que lorsqu'ils sont extrêmement prêts du ravitailleur (en fait le panier apparait lorsque le client est en position d'être connecté)

***********************************

Q : dans une partie réseau, je ne peux plus utiliser la commande de trim car la fenêtre de chat apparait à la place, comment faire ?

R : C'est un bug lié au clavier français (AZERTY). Pour corriger ce problème, il faut changer les touches de la commande de trim haut/bas. Pour cela, référez vous à l'illustration ci-dessous :

Image

***********************************

Q: Je suis sous XP et je ne peux hoster une partie en multijoueur.

R: Vérifiez que le firewall de XP n'est pas fonctionnel. Si il l'est, désactivez-le.
Pour le désactivez regardez dans les propriétés de votre connexion.
Image



Rafale News : le blog du rafale

:cheer: Rafale ! Rafale ! Rafale ! :cheer:
Avatar de l’utilisateur

Topic author
Kovy
Chef de patrouille
Chef de patrouille
Messages : 4723
Inscription : août 2001
Localisation : Paris
Contact :

Message #6 par Kovy » 04 déc. 2003, 16:00

Avionique, utilisation des avions :


Q : sur le F-15 quand je passe du mode TWS aux modes boresight ou vertical scan puis que je reviens en TWS, le réglage de l'élévation de l'antenne ne fonctionne plus.

R : c'est un bug qui devrait être résolu avec le patch.

********************************

Q : lorsque je viens de terminer un ravitaillement en vol, la manette des gaz semble ne plus fonctionner, Que ce passe t-il ?

R : l'automanette est activée, appuyez sur J pour la désactiver.

*********************************

Q : quand je suis en pilote automatique, que l'avion fait un virage et que je désactive le pilote automatique à ce moment là, l'avion devient incontrolable, que ce passe t-il ?

R : il faut réinitialiser les trim avec "CTRL + T" ou éviter de désactiver le Pilote auto pendant un virage.

*********************************

Q : Pourquoi les avions sont ils toujours à cabré ? Ils ont toujours tendance à vouloir à tout prix monter, même en réduisant les gaz !!!

R : A part le F-15 qui a une trim auto (enfin, faut lui laisser le temps de reagir quand même) tous les autres avions doivent être trimés en permanance des que la vitesse change, avec les touches :

ctrl m trim bas
ctrl : trim haut

et dans une moindre mesure,
ctrl ! trim droit
ctrl ; trim gauche
trim lacet : CTRL w et CTRL x

*********************************

Q : Comment allume t-on les moteurs de son avion ?

R : il faut appuyer sur la touche "'page up" (à gauche du verr num). Il faut ensuite environ 50 secondes pour que les moteurs s'allument.
CTRL - "page up" et ALT - "page up" permettent d'allumer les 2 moteurs séparément.
Pour éteindre les moteurs, "page down"
Image



Rafale News : le blog du rafale

:cheer: Rafale ! Rafale ! Rafale ! :cheer:
Avatar de l’utilisateur

Topic author
Kovy
Chef de patrouille
Chef de patrouille
Messages : 4723
Inscription : août 2001
Localisation : Paris
Contact :

Message #7 par Kovy » 08 déc. 2003, 12:13

Missions d'entrainement, Campagne, Editeur.

Q : Les missions d'entrainement ne fonctionnent pas correctement : Au bout de quelques instants, le regard du pilote se bloque et le texte ne concorde plus avec les instruments indiqués par la souris, comment faire ?

R : Il peut y avoir plusieurs causes à ce problème.

- il ne faut surtout pas toucher au clavier pendant une mission d'entrainement (sauf la touche S pour faire des pauses)
- il ne faut pas que la souris soit assignée aux mouvements de la tête du pilote (menu option > cockpit > cockpit mouse désactivé)
- il faut que l'angle de vue soit réglé sur 60 ° (menu option > cockpit > angle de vue = 60)
- il faut que les mirroirs soient désactivés (essayez avec, normalement ça marche quand même)

************************************
Q : Comme faire un track commenté ?

R : voir cet article

************************************
Q : Comme faire une mission avec l'éditeur de mission?

R : voir cet article

************************************
Q : Ou se trouvent les plate forme off shore et les champs de pétrôle ?

R : Ici

Image

Image

Image

Image

Image
Image



Rafale News : le blog du rafale

:cheer: Rafale ! Rafale ! Rafale ! :cheer:
Avatar de l’utilisateur

Oxitom
As du Manche
As du Manche
Messages : 11399
Inscription : août 2001
Localisation : Paris
Contact :

Message #8 par Oxitom » 05 janv. 2004, 01:57

Update du 5 janvier 2004

-Q: Mon pc plante (reboot) en plein jeu.
-R: essayer en desactivant l'option fast Write dans le bios (appuyer sur la touche suppr lors de l'affichage de la ram au demarrage de l'ordi pour acceder au bios).
Avatar de l’utilisateur

Oxitom
As du Manche
As du Manche
Messages : 11399
Inscription : août 2001
Localisation : Paris
Contact :

Message #9 par Oxitom » 02 juin 2004, 16:45

SONS

Par Sweep.
Procédure d'installation du Pack Son US :

SUIVEZ BIEN LA PROCEDURE :

1 - Créer où vous voulez un dossier Temporaire appellé "Sons_Tempo"

2 - Dans ce Dossier, créer un répertoire "Sounds"

3 - Dézipper le contenu du fichier "Sounds.zip" dans le dossier "Sounds" (conserver les arborescences)

4 - Allez sur le CD de Lomac, répertoire "Util" et copier tous les fichiers s'y trouvant
(deogg.exe etc...) dans le dossier "Sons_Tempo"

5 - Allez dans le dossier "Sons_Tempo" et executez Deogg.exe

6 - Une fois la décompression effectuée, allez examiner les différents sous-dossier contenus dans "Sounds", vous y verrez deux occurences pour chaque fichier : 1 en version .OGG et l'autre en version .WAV

7 - Eliminez tous les fichiers .OGG de tous les sous dossiers

8 - Renommer le Dossier "Sounds" se trouvant dans votre répertoire LockOn (Disque Dur) en "Sounds-FR"

9 - Copier le répertoire "Sounds" (se trouvant dans votre répertoire "Sons_Tempo") dans votre répertoire LockOn (disque Dur)

10 - Votre dossier LockOn contient donc maintenant les deux sous-dossiers suivants : "Sounds-FR" et "Sounds"

11 - Dans le dossier "Sounds", allez dans le sous-dossier "EnglishVersion" puis le sous-dossier "RF" : Vous constatez qu'il manque le dossier du Wingman 1

12 - Créer ce dossier WINGMAN 1

13 - Faîtes y un copier-coller des fichiers se trouvant dans un des autres répertoires "WINGMAN" du dossier ( personnellement, j'ai pris ceux du dossier "WINGMAN 3" )

14 - Allez dans votre répertoire "Sounds-FR" copier le dossier "Music" ainsi que les deux fichiers "plane.cfg" et "sound.cfg" dans le repértoire "Sounds"

15 - Allez dans votre répertoire "Sounds-FR", allez dans le sous-dossier "FrenchVersion" faites une copie du répertoire "GER" s'y trouvant et mettez-la dans le sous-dossier "EnglishVersion" du dossier "Sounds"

16 - Allez dans votre dossier "Sounds" et renommez le dossier "EnglishVersion" en "FrenchVersion" (sinon ça ne marchera pas)

17 - Allez dans votre pharmacie cherchez la boîte d'Alka-Seltzer et avallez donc un tube entier tout en méditant sur les bienfaits des logiciels d'installation automatique. (c'est une blaque, prenez juste un cachet ça suffira ^_^ )


FIN
Avatar de l’utilisateur

fantomas
Mécano au sol
Mécano au sol
Messages : 454
Inscription : février 2004
Localisation : reims/cambrai
Contact :

Modification de la couleur des feux de nav

Message #10 par fantomas » 28 févr. 2005, 23:10

[edit Az'] Suite à une question de Dobberman, voici une méthode pour modifier la couleur des feux de navigation. Fonctionne en 1.02, à vérifier en 1.1x.
ATTENTION ceci modifie toutes les lumières (exemple : celles du pont du Kuz).


Originally posted by Oxitom@28 Feb 2005, 18:48
C'est une texture tga, y'as le vert, le rouge et le blanc, normalement elle doit s'appeler bano ou quelque chose du genre.

c'est exatement ça bano.tga a mettre dans bazar/temptexture


Et pour les fumis y'a pas de texture ?


s'il existait une texture pour les fumis dans 1.02 il y a longtemps que le bms volerai avec des couleurs differentes, en revanche il est possible de modifier les couleurs dans la 1.1 (en plus des couleurs existantes,rouge,jaune,orange....)

Merci à Oxitom et Fantomas pour la solution :yes:
tous les avions sont à train rentrant...pour certains il faut se poser un peu plus dur......

Brigand 23 Brigand Mike Squadron
Avatar de l’utilisateur

Oxitom
As du Manche
As du Manche
Messages : 11399
Inscription : août 2001
Localisation : Paris
Contact :

Message #11 par Oxitom » 28 juin 2005, 23:41

Micro freezes version 1.1

Rapport et traduction de Berkoutskaia (post):

Je transmet ici l'info donnée sur le forum officiel. Il s'agit d'une manip a éffectuer pour corriger les microfreezes apparaissant à chaque fois que l'AWACS annonce un groupe de bandit.

La méthode est la suivante:
-télécharger et installer le pack OggVorbis ici
-dans WINDOWS\System32, copier les fichiers ogg.dll, OggDS.dll, vorbis.dll et vorbisenc.dll.
-coller ces fichiers dans le répertoire d'installation de LO:FC. Ecrasez au besoin les anciennes versions.

Et voilà,

merci HUQ pour l'info !
Avatar de l’utilisateur

Phil
WSO Co-pilote
WSO Co-pilote
Messages : 898
Inscription : août 2001
Localisation : 06
Contact :

Message #12 par Phil » 14 sept. 2005, 18:33

Q: "Si je formate,comment reinstaller lockon sans griller une cartouche sur starforce..................merci,"


R: "Il faut, avant de formater, utiliser l'utilitaire de sauvegarde de clé (nom = LockOn_Save_Registry) disponible sur lockon.ru (section files > downloads)

1) Récupérer le fichier .reg créé par cet utilitaire (avant donc de formater, of course)
2) formater puis réinstaller windows
3) réinstaller LO puis FC (ne pas lancer le jeu)
4) enfin exécuter le fichier .reg pour réinsérer la clé dans la base de registre.
5) voler !

Vala, pour ceux qui ne veulent pas formater le PC mais juste désinstaller LO+FC, un nouveau désinstalleur qui sauvegarde lui aussi la clé de registre pour starforce est dispo en section files > fixes sur lockon.ru"

Merci à romingo pour la question et à Azrayen pour la reponse ;-)
Avatar de l’utilisateur

ezechiel203
Jeune Pilote
Jeune Pilote
Messages : 1090
Inscription : septembre 2004
Localisation : Lille
Contact :

Modification de la couleur des fumis (LO 1.1)

Message #13 par ezechiel203 » 01 sept. 2006, 21:29

[edit Az'] Repris d'un autre sous-forum, voici la méthode pour modifier les couleurs de fumis disponibles. Attention : ne fonctionne qu'avec LOFC 1.1 ou supérieur.
Merci @ Ezechiel pour cette solution.


Amis du soir bonsoir!
Voici la solution pour modifier les couleurs de fumis :
ouvrez le fichier drawinfo.lua situé dans config/weapons
Vous y trouverez des lignes de code telles que :

Smokes[67] = {
alpha = 180,
r = 245,
g = 40,
b = 40,
dx = 2.0,
dy = 0.09
} -- red AIM-9S

Smokes[87] = {
alpha = 180,
r = 50,
g = 160,
b = 90,
dx = 2.0,
dy = 0.09
} -- green AIM-9S

Smokes[88] = {
alpha = 180,
r = 50,
g = 100,
b = 210,
dx = 2.0,
dy = 0.09,
} -- blue AIM-9S

etc etc etc
(ici j'ai pris des pods américains, mais les pods russes sont présents aussi au dessus).
Choisissez la couleur de vos fumis en format RGB et modifiez les paramètres r, g et b du code dans le fichier. enregistrez, volez :)
(pensez quand même à faire une copie de sauvegarde du fichier à l'avance!!)
On peut faire des choses bien hideuses!!

Image
[align=left]
[align=center]Image[align=left]

MISE A JOUR DU 4/09/2006. Correction de bugs. DétailsICI. (compatible v1.12/1.12a ET b)
erreur d'installation, problème? [email="ezechiel203@ifrance.com"]c[/email][email="ezechiel203@ifrance.com"]ontact[/email]

[/align]
[/align]
[/align]
Avatar de l’utilisateur

Oxitom
As du Manche
As du Manche
Messages : 11399
Inscription : août 2001
Localisation : Paris
Contact :

Message #14 par Oxitom » 26 sept. 2006, 20:14

Trajectoire de vol erratique des autres clients lors d'un vol en réseau.

Propos de Major bug repris de ce post:

Etape 1 : allez dans /Lock On/config/network/ . Là vous trouverez un fichier qui s'appelle config.lua . Faites-en une copie que vous appellerez config2.lua .

Etape 2 : revenez dans le répertoire /Lock On/ . Créez un nouveau fichier texte que vous ouvrez avec le notepad windows (et surtout pas le wordpad !). A l'intérieur copiez ce petit script :

@echo off
cd Config
cd network
del config.lua
copy config2.lua config.lua
cd ..
cd ..
LockOn.exe


Etape 3 : enregistrez le fichier texte et appellez-le ou renommez-le xxx.bat, le xxx étant laissé à votre convenance, excepté lockon.bat qui est déjà occupé :tongue:

Etape 4 : créez un raccourci vers votre xxx.bat et utilisez-le pour lancer le jeu à chaque fois ;)

Et voila, fini le config.lua qui saute tout le temps :yes:

Fichier de rechange envoyé par neo 68.
Avatar de l’utilisateur

Oxitom
As du Manche
As du Manche
Messages : 11399
Inscription : août 2001
Localisation : Paris
Contact :

Message #15 par Oxitom » 26 sept. 2006, 20:19

Double installation Lock-on 1.02/ lock-on FC.

Propos de Azrayen repris de ce post.

1. installation 1.02 dans le répertoire par défaut (appellons le "A" pour simplifier)
2. copie de tout le répertoire "A" à un autre endroit (exemple : ton bureau) Ceci crée un répertoire "B" copie conforme de "A". Renomme "B" pour qu'il n'ait plus le même nom que "A" (exemple : "LO 1.02")
3. installation de Flaming Cliffs dans "A"
4. déplacement de "B" de ton bureau vers le répertoire parent (= celui qui contient) "A" (il est maintenant possible de les avoir côte à côte puisqu'ils n'ont plus le même nom depuis l'étape 2). Cette étape sert juste à éviter d'avoir Lockon qui traine sur ton bureau.

=> pour lancer FC, raccourci ou double clic sur Lockon.exe dans "A"
=> pour lancer la 1.02, double clic sur Lockon.bat dans "B"

Si tu ne vois pas les extensions (.exe, .bat ...) : Ouvre un répertoire (n'importe lequel). Menu Outils > Options des dossiers. Onglet "Affichage" > décoche la case "Masquer les extensions des fichiers dont le type est connu" et valide par "OK".




Double/multi installation Lock-on FC.

Q : Comment faire pour disposer de plusieurs "instances" de LOFC qui cohabiteraient sur son PC ? (généralement afin d'installer sur l'une ou l'autre instance des mods incompatibles entre eux)

R : A partir d'une installation "propre" de LO+FC+patch officiel (1.12a ou 1.12b) à l'exclusion de toute autre modif, copiez votre répertoire LockOn et collez-le juste à côté. Vous obtenez un répertoire "copie de Lock On" que vous pouvez renommer à votre guise, contenant tous les fichiers nécessaires au jeu.
Lancez l'une ou l'autre des instances via un raccourci adapté, pointant sur le bon lockon.exe

Notez qu'il est aussi possible, en bidouillant un peu les fichiers de conf et en créant plusieurs répertoires "addons", de faire en sorte que ModMan gère ces Double/multi installation.

++
Az'
Avatar de l’utilisateur

Oxitom
As du Manche
As du Manche
Messages : 11399
Inscription : août 2001
Localisation : Paris
Contact :

Message #16 par Oxitom » 26 sept. 2006, 20:25

Impossible d'installer le patch 1.12a sur lock-on Gold.

nodeug a écrit :J'ai installé LockOn Gold, version CD anglaise, mais impossible d'installer le patch 1.12a sur ma nouvelle install.

J'ai le message suivant qui s'affiche : "Error occured during installation. Error code is 2. Setup is not completed."

Que faire ? Où peut se situer le problème ? j'ai essayé plusieurs versions téléchargées.

Merci


Et la réponse qui vas bien de Curli.

A priori il existe un NOUVEAU patch pour les gens qui possede lockon GOLD....

Daté du 30 Mai 2006.

Ici.

a+
Avatar de l’utilisateur

Azrayen
Moderateur
Moderateur
Messages : 15343
Inscription : décembre 2004
Localisation : Un faubourg du ponant de Lutèce
Contact :

Message #17 par Azrayen » 12 janv. 2007, 17:15

[SIZE="4"]Q : Comment faire pour régler correctement le ratio hauteur/largeur de l'affichage ?[/SIZE]
(utile pour tous les écrans "wide" notemment sur LO & FC1, et les "triple écrans" sur toutes versions de LO)

[color="Pink"][SIZE="4"]LO & FC1 :[/SIZE][/color]
R : [SIZE="1"](merci @ STEFOSTEF & maitretomtom dans ce sujet)[/SIZE]
1] Dans les options du simu, passer en 1680x1050 [SIZE="1"](ou votre résolution, ici on prend un exemple)[/SIZE]
2] Editer le fichier \Lock On\Config\graphics.cfg et régler les paramètres "aspect" comme suit :

Code : Tout sélectionner

DisplayMode
{
resolution = {[B][color="Lime"]1680, 1050[/color][/B]};
bpp = 32;
fullscreen = 1;
aspect = [B][color="Lime"]1.6[/color][/B];
Interface
{
resolution = {[B][color="Lime"]1680, 1050[/color][/B]};
bpp = 32;
fullscreen = 1;
aspect = [B][color="Lime"]1.6[/color][/B];
}
Simulation
{
resolution = {[B][color="Lime"]1680, 1050[/color][/B]};
bpp = 32;
fullscreen = 1;
aspect = [B][color="Lime"]1.6[/color][/B];
}


Quelle valeur utiliser ?
C'est L / l => exemple 1680/1050 = 1,6
A vos calculettes en fonction de votre résolution ;)

Autre solution, si vous disposez de la version 1.12a : Utilisez LOCFG, avec cet utilitaire, plus besoin de bidouiller à la main. :yes:
[color="Yellow"]
Attention : Chaque fois que vous toucherez aux options graphiques via les menus de LO, le simu remet la valeur par défaut (1.333333) en "aspect".[/color]
=> Il faut donc à chaque fois revenir, à la main ou via LOCFG, remettre le paramètre qui va bien. C'est un peu lourd, mais c'est LO et non il n'y a rien à faire pour l'éviter [SIZE="1"](à part éviter de tripatouiller ses options tous les 4 matins)[/SIZE].
[SIZE="1"]Merci @ Philippe22 & Romaniak pour avoir fait préciser ce point :)[/SIZE]


[color="Pink"][SIZE="4"]FC2 (& BS) :[/SIZE][/color]
Le ratio se règle désormais dans le simu... sauf que toutes les valeurs ne sont pas dispos. En mono-écran, c'est généralement OK, mais pas pour les "triple head" et autre solutions bi/multi-écrans.
Le principe est le même que pour LO/FC1, allez éditer le fichier qui va bien pour modifier le paramètre "aspect".

Dans FC2, le fichier à éditer est options.lua dans le répertoire \BlackShark\data\scripts de votre install FC2. Vers la fin du fichier, vous avez la section concernant les graphismes :

Code : Tout sélectionner

    ["graphics"] =
    {
        ["multiMonitorSetup"] = "1camera",
        ["color"] = "32",
        ["heatBlr"] = 1,
        ["scenes"] = "high",
        ["water"] = 2,
        ["fullScreen"] = false,
        ["visibRange"] = "Medium",
        ["aspect"] = [color="Lime"][B]1.6[/B][/color],
        ["textures"] = 2,
        ["shadows"] = 2,
        ["effects"] = 3,
        ["width"] = [color="Lime"]1680[/color],
        ["lights"] = 2,
        ["height"] = [color="Lime"]1050[/color],
        ["civTraffic"] = 0,
        ["resolution"] = "[color="Lime"]1680x1050[/color]",
        ["haze"] = 1,
    }, -- end of ["graphics"]
Image Image

Image
Avatar de l’utilisateur

Azrayen
Moderateur
Moderateur
Messages : 15343
Inscription : décembre 2004
Localisation : Un faubourg du ponant de Lutèce
Contact :

Message #18 par Azrayen » 01 avr. 2007, 12:29

[SIZE="4"]PROBLEMES DE TRACK-IR[/SIZE]

[SIZE="4"]Q : Mon track-ir ne réagit plus dans LO 1.0x ou FC 1.1x, comment faire ?[/SIZE]

R : Après avoir vérifié que ce n'est pas un pb de matos / config (i.e. votre track-ir fonctionne dans d'autres simus), effacez le fichier Lock On\Input\TrackIR.ini puis relancez dans l'ordre
- le Track-Ir
- Lock-On
Le fichier sera recréé avec les bons paramètres. Pour info ce souci survient notamment si vous avez lancé LO sans lancer le Track-Ir.

Et pour les flemmards, voici comment régler le souci sans avoir à se soucier de son éventuelle réapparition ;)


[SIZE="4"]Q : Mon track-ir ne réagit pas dans FC2 1.2.x, comment faire ?[/SIZE]

R : Vous devez mettre à jour la liste des jeux connus de votre Track-Ir pour que celui-ci fonctionne avec FC2 (note : c'est pareil pour DCS).
Pour cela : Track-Ir => Update => Check for Games Updates... (avec une connexion internet active, bien sûr).

Il n'y a plus le pb de fichier "trackir.ini" cité ci-dessus dans FC2 (ni dans DCS).

++
Az'
Image Image

Image
Avatar de l’utilisateur

Oxitom
As du Manche
As du Manche
Messages : 11399
Inscription : août 2001
Localisation : Paris
Contact :

Message #19 par Oxitom » 23 juin 2007, 22:19

[SIZE="4"]Q: J'ai lockon flaming cliffs en version CD et starforce me bloque.[/SIZE]

R: S'assurer que l'on a bien installé lockon et ses patchs.
Lock-on 1.0 (CD)
Lock-on FC 1.1 (CD)
Patch 1.12b correspondant a votre achat dispo apres log-in sur lockon.co.uk.

Laisser le cd dans le lecteur avant de lancer lock-on.

Merci aux différents interlocuteurs sur ce post.
Avatar de l’utilisateur

Oxitom
As du Manche
As du Manche
Messages : 11399
Inscription : août 2001
Localisation : Paris
Contact :

Message #20 par Oxitom » 18 août 2007, 21:08

[SIZE="4"]Q:J'ai téléchargé une livrée, l'ai installée avec modman, mais dans le jeu lorsque je vole avec mon avion, il n'as pas cette livrée.[/SIZE]

R: Lock-on ne permet pas de choisir une skin lorsque l'on prend une mission déja prête. Il faut soit ouvrir la mission dans l'editeur soit en créer une. Dans le vol attribué au joueur, cliquer sur la case emport (payload) ensuite dans la nouvelle fenetre qui s'affiche, regarder en bas a gauche le menu déroulant livrées (paint schemes) et afficher les skins une par une avant de trouver la bonne. Ensuite enregistrer la mission et cliquer sur voler (fly).
Avatar de l’utilisateur

Flaps
Chef de patrouille
Chef de patrouille
Messages : 5128
Inscription : juillet 2004
Localisation : Clermont Ferrand
Contact :

Message #21 par Flaps » 01 mars 2008, 21:32

Q : Lorsque je lance un partie multijoueur les écritures en haut de l'écran restent affichées et ne disparaissent jamais.

R : Allez dans C:\Program Files\Ubisoft\Eagle Dynamics\Lock On\Config\network et remplacer le fichier Config.lua par un fichier neuf (demander a quelqu'un ayant la même version de lockon ou sauvegarder sont Config.lua propre )
__________

Image

Image
Avatar de l’utilisateur

GI-jo
Nouvelle Recrue
Nouvelle Recrue
Messages : 86
Inscription : décembre 2007
Localisation : Marseille

Message #22 par GI-jo » 06 mars 2008, 19:57

Salut,
je viens d'acheter lo qui c'est charger normalement (avec vista) mais quand je lance le jeu un message d'erreur apparait; ( this application has required the runtime to terminate it in an unusual key.) j'ai le son d'intro. la version est un cd acheté chez surcouf qui peut me dépanner?
je souligne toutefois que le logiciel ne m'as pas demandé une clé e débloquage, que je n'ai pas trouvée d'ailleurs!
merci à+
Avatar de l’utilisateur

Ariomatov
Nouvelle Recrue
Nouvelle Recrue
Messages : 3
Inscription : avril 2008

lock on gold vista runtime error

Message #23 par Ariomatov » 12 avr. 2008, 15:41

Q : j'ai installé lock-on gold (lock on de base + FC sur CD) ainsi que le patch 1.12b pour vista, mais à chaque fois que je lance lock-on, j'entend le son de début mais on m'affiche une erreur "runtime error Visual C++"


R : Vous devez désactiver l'UAC de windows Vista. La procédure est simple et disponible ici (si le lien meurt, cherchez comment désactiver l'UAC de vista sur un moteur de recherche) : http://www.zebulon.fr/astuces/220-desactiver-l-uac-dans-vista.html

Il est possible après cela que votre fichier LockOn.exe ne fonctionne toujours pas, même en mode administrateur. Néanmoins un double-click sur LockOn.bat (dans dossier principal de LockOn) devrait lui réellement éluder ce problème de "runtime error".
Avatar de l’utilisateur

Azrayen
Moderateur
Moderateur
Messages : 15343
Inscription : décembre 2004
Localisation : Un faubourg du ponant de Lutèce
Contact :

Message #24 par Azrayen » 22 juin 2008, 21:08

/bump

ajout (post #15) de la procédure pour disposer de plusieurs "installs" (je préfère instances) de Flamming Cliffs, afin de pouvoir utiliser des mods incompatibles entre eux.
Image Image

Image

Revenir vers « Support technique »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 0 invité