B.A.T. (ex C.U.P.) Battlefield-Airborne-Tactical

Salle dédiée aux "MODS" pour IL2-1946
Guides, support et discussions sur les mods de Il2-1946.
Avatar de l’utilisateur

Topic author
C6_Dore
Jeune Pilote
Jeune Pilote
Messages : 1083
Inscription : 30 juin 2006

Re: B.A.T. (ex C.U.P.) Battlefield-Airborne-Tactical

#51

Message par C6_Dore » mer. juin 07, 2017 12:50 pm

Image
Avatar de l’utilisateur

canauos
Jeune Pilote
Jeune Pilote
Messages : 1439
Inscription : 26 août 2014

Re: B.A.T. (ex C.U.P.) Battlefield-Airborne-Tactical

#52

Message par canauos » mer. juin 07, 2017 4:32 pm

Merci pour l'historique !
Ma configue : I5 3570k 4,4 ghz, GTX 1060 6gb, 16go de ram DDR 3, SSD.
Mon matos simulation aérienne : HOTAS Warthog, grip F/A-18C avec rallonge Sahaj de 10 cm, mod TDC Delta Sim, support Monstertech version longue, MFD Cougar, palonnier TPR, HOTAS T16000M FCS, Track Ir 5.
Mon matos simulation automobile : volant Thrustmaster TS-PC Racer, addon Ferrari 599XX EVO, T3PA Pro, TH8A, TSS HANDBRAKE SPARCO.
Mon code de parrainage Star Citizen, en espérant qu'il sorte un jour : STAR-WDGN-DBJT

TTIKO
Nouvelle Recrue
Nouvelle Recrue
Messages : 156
Inscription : 29 septembre 2002

Re: B.A.T. (ex C.U.P.) Battlefield-Airborne-Tactical

#53

Message par TTIKO » jeu. nov. 09, 2017 1:53 pm

Bonjour tout le monde, Egun on, apres quelques années d'absences je reviens vers vous car je viens de réinstaller IL2 1946 version steam, j'ai téléchargé le mod BAT et la tout va biens!! mais j'aimerais telecharger un certain nombre de campagnes ou de missions, faut il qu'elles soient spécialement pour ce MOd et j'aimerais jouer des campagnes françaises lesquelles me conseillaient vous ? merci de votre reponse!!

platounet
Nouvelle Recrue
Nouvelle Recrue
Messages : 38
Inscription : 14 mai 2009

Re: B.A.T. (ex C.U.P.) Battlefield-Airborne-Tactical

#54

Message par platounet » ven. mai 18, 2018 9:01 pm

bonsoir
Je suiis en BAT avec 4.12. Comment passer en BAT 4.13 sans tout reinstaller? ESTéce possible? Merci pour la réponse
Avatar de l’utilisateur

Gaston
Chef de patrouille
Chef de patrouille
Messages : 5714
Inscription : 13 janvier 2003

Re: B.A.T. (ex C.U.P.) Battlefield-Airborne-Tactical

#55

Message par Gaston » ven. mai 18, 2018 10:41 pm

Non, pas possible. BAT, ça marche en 4.12. Pas en 4.13.
Avatar de l’utilisateur

CdtLapin
Nouvelle Recrue
Nouvelle Recrue
Messages : 85
Inscription : 28 mars 2019

Re: B.A.T. (ex C.U.P.) Battlefield-Airborne-Tactical

#56

Message par CdtLapin » sam. juin 15, 2019 12:44 am

TTIKO a écrit :
jeu. nov. 09, 2017 1:53 pm
Bonjour tout le monde, Egun on, apres quelques années d'absences je reviens vers vous car je viens de réinstaller IL2 1946 version steam, j'ai téléchargé le mod BAT et la tout va biens!! mais j'aimerais telecharger un certain nombre de campagnes ou de missions, faut il qu'elles soient spécialement pour ce MOd et j'aimerais jouer des campagnes françaises lesquelles me conseillaient vous ? merci de votre reponse!!
Gau on Ttiko!
Nola zara?
Un autre Basque:à la bonne heure.
Pour répondre à ta question, malgré que tu as sans doute trouvé la réponse, depuis un an..
Il n'y a pas de réponse certaine, de règle.
Les missions sont faites avec des cartes, des objets, des avions, etc qui peuvent ne pas être présents d'un mod à l'autre ou référencés autrement.
En principe, l'auteur indique pour quel mod il a fait ses missions ou sa campagne, mais ça indique surtout DANS quel mod il a travaillé. Il est sûr que ça marchera.
Donc il faut essayer, si c'est plausible (mêmes cartes etc) ça ne corrompra pas ton installation: simplement la mission ne se chargera pas ou des objets auront disparu.
Tu n'auras donc qu'à la supprimer OU A L'EDITER.
Moi qui te parle, j'ai eu la surprise (alors que mes vieilles missions s'ouvrent dans tous les mods (qui ont conservé les cartes et les avions d'origine), de voir une mission éditée par moi dans BAT s'ouvrir dans VP... mais sans les 7 flights de quatre appareils (des C47, car ils ne sont pas du même modèle, de la même année et n'ont pas les mêmes noms dans chacun des deux mods). Oui, je voulais voir si les parachutes s'ouvraient sur les ntracks de VP alors qu'ils partent en torche sur ceux de BAT.
En principe toutes les vieilles missions de CUP et de Bat sont ouvrables dans BAT v3.6.2 'The Blitz".
Bien sûr, il peut y avoir des exceptions (mais il y en a tellement à disposition!!!!!).
Pour les "campagnes françaises" si tu parles de la Bataille de France (mai-juin 40) je n'ai trouvé la bonne carte que dans VP mod.
Donc dans Bat, tu devras te contenter des cartes du Channel en 40 (Bataille d'Angleterre).
Ikus artio.
Avatar de l’utilisateur

Bed
Nouvelle Recrue
Nouvelle Recrue
Messages : 91
Inscription : 01 septembre 2004

Re: B.A.T. (ex C.U.P.) Battlefield-Airborne-Tactical

#57

Message par Bed » lun. août 19, 2019 9:48 pm

Hello tous,

Je viens (suite discussion sur d'autres posts) d'installer BAT jusque Checkpoint 3.0 dans un premier temps.
Aucun souci d'install, de config, de selection de période, de lancement et j'ai corrigé le MIL 24 tout rose effectivement: Tout va bien !

Sauf que .. , je ne trouve aucune campagne, ni aucune mission, c'est très très pauvre.
J'ai parcouru les docs BATx et normalement une campagne Espagne Guerre civile doit s'y trouver avec ce CP 3.0.
Rien dans IL2: en carriere comme en mission simple.

Dans l'arborescence Windows effectivement, je ne trouve aucun fichier .mis sous les répertoires Missions/campaign/SK ou SP
Je ne vois rien dans JSGME (et ce serait surprenant pour une campagne)

Quelque chose m'échappe ...

Merci si vous avez une idée sur l'erreur de j'ai du commettre (installation ou mauvaise compréhension du manuel)
Avatar de l’utilisateur

CdtLapin
Nouvelle Recrue
Nouvelle Recrue
Messages : 85
Inscription : 28 mars 2019

Re: B.A.T. (ex C.U.P.) Battlefield-Airborne-Tactical

#58

Message par CdtLapin » lun. août 19, 2019 10:37 pm

Salut Bed,
Non, si ton jeu se lance, tu n'as pas fait d'erreurs.
Je ne connaissais pas BAT, il y a moins d'un an.
A l'époque, la dernière version était la 3.5 Musketeer.
J'ai tout installé successivement sans explorer la 3.0, la 3.1, la 3.2, la 3.3, la 3.4.
Je ne me souviens pas des campagnes: je préfère les missions isolées (dossier Single).
J'ai d'abord éditées et rééditées celles que j'avais de mes débuts (et qui ne démarraient plus) pour les adapter à BAT et en ai créées d'autres (des missions, pas des campagnes).
Ce sont d'ailleurs des WIP.
La 3.7 "Le Grand Cirque"vient de sortir et je l'ai installée (sur la 3.6.2 "The Blitz").
Je viens de regarder: il n'y en a en effet que deux campagnes.
C'est sûrement un point faible de BAT: les moddeurs ne peuvent tout faire.

Tu en trouveras sur les sites consacrés à IL2 1946, créées, elles, par des joueurs.

J'en ai moi-même téléchargé, mais n'y ai pas encore touché, faute de temps pour le moment.
C'est tout ce que je peux te dire.
Avatar de l’utilisateur

Bed
Nouvelle Recrue
Nouvelle Recrue
Messages : 91
Inscription : 01 septembre 2004

Re: B.A.T. (ex C.U.P.) Battlefield-Airborne-Tactical

#59

Message par Bed » mar. août 20, 2019 8:28 am

Hello,
Ok merci.
J'ai tout de même installé la version 3.1 Sealion, et là en revanche, j'ai bien 2 fois 4/5 campagnes coté RAF et coté LW pour la bataille d'Angleterre dans Carriere.
Les campagnes sont indiquées avec les symbole du Pique (du jeu de carte)

Je vois de voir la 3.7 et un autre post sur le site SAS proposant des centaines de missions (pas forcément campagne) fonctionnant à partir de la 3.7.
Apparemment beaucoup de missions training, y'a peut être des trucs sur les Hélicos ;-)
Avatar de l’utilisateur

jeanba
As du Manche
As du Manche
Messages : 11110
Inscription : 17 septembre 2001

Re: B.A.T. (ex C.U.P.) Battlefield-Airborne-Tactical

#60

Message par jeanba » mar. août 20, 2019 11:13 am

CdtLapin a écrit :
lun. août 19, 2019 10:37 pm
Salut Bed,

Je ne me souviens pas des campagnes: je préfère les missions isolées (dossier Single).
J'ai d'abord éditées et rééditées celles que j'avais de mes débuts (et qui ne démarraient plus) pour les adapter à BAT et en ai créées d'autres (des missions, pas des campagnes).
Ce sont d'ailleurs des WIP.
La 3.7 "Le Grand Cirque"vient de sortir et je l'ai installée (sur la 3.6.2 "The Blitz").
Je viens de regarder: il n'y en a en effet que deux campagnes.
C'est sûrement un point faible de BAT: les moddeurs ne peuvent tout faire.

Tu en trouveras sur les sites consacrés à IL2 1946, créées, elles, par des joueurs.

J'en ai moi-même téléchargé, mais n'y ai pas encore touché, faute de temps pour le moment.
C'est tout ce que je peux te dire.
Tu as un "community pack" dispo ici:
https://www.sas1946.com/main/index.php/ ... 119.0.html

et mission4today a toujours été la référence pour les campagnes, mais il faut bien lire les compatibilités.
Avatar de l’utilisateur

CdtLapin
Nouvelle Recrue
Nouvelle Recrue
Messages : 85
Inscription : 28 mars 2019

Re: B.A.T. (ex C.U.P.) Battlefield-Airborne-Tactical

#61

Message par CdtLapin » mar. août 20, 2019 4:02 pm

Merci, Jeanba.
Avatar de l’utilisateur

CdtLapin
Nouvelle Recrue
Nouvelle Recrue
Messages : 85
Inscription : 28 mars 2019

Re: B.A.T. (ex C.U.P.) Battlefield-Airborne-Tactical

#62

Message par CdtLapin » mar. août 20, 2019 4:18 pm

Bed a écrit :
mar. août 20, 2019 8:28 am
Hello,
Ok merci.
J'ai tout de même installé la version 3.1 Sealion, et là en revanche, j'ai bien 2 fois 4/5 campagnes coté RAF et coté LW pour la bataille d'Angleterre dans Carriere.
Les campagnes sont indiquées avec les symbole du Pique (du jeu de carte)

Je vois de voir la 3.7 et un autre post sur le site SAS proposant des centaines de missions (pas forcément campagne) fonctionnant à partir de la 3.7.
Apparemment beaucoup de missions training, y'a peut être des trucs sur les Hélicos ;-)
Des centaines de missions, déjà????
Non, je rigole, en fait campagnes et missions proposées pour CUP et les anciennes versions de BAT DEVRAIENT marcher avec BAT.

Toutefois, c'est à vérifier soigneusement car dans le post faisant la promo de BAT 3.7 et donnant les liens pour la télécharger, il y a quelques lignes sur les "old" missions et le FMB.
Pour l'instant celles que j'ai vérifiées fonctionnent.
Dans le QMB pareil.
Il y en a bien quelques unes (une vingtaine?) installées avec BAT, mais seulement deux campagnes par défaut pour la 3.7 (une sur le P38, l'autre intitulée" Le Grand Cirque", qui débute sur Spitfire MkV et qui doit probablement s'inspirer du livre de Closterman.
Tout ce que tu peux trouver doit être ajouté à BAT.
Missions et campagnes, très faciles à créer (une fois qu'on a compris comment le FMB fonctionne, sont l'oeuvre de joueurs (qui peuvent évidemment être des modders aussi, et même auteurs dans BAT).
Avec les skins, ce sont bien les SEULS fichiers (vérifier le nom du dossier qui doit être strictement le même que dans les fichiers air.ini des modules, pour que le jeu les trouve) que l'on peut ajouter à BAT et surtout....on n'enlève rien.
BAT est un "mod" que (moi au moins) je ne suis pas arriver à modifier avec un mod ponctuel (moteurs et hélices du B26B par exemple, vraiment pas terribles : un modder a corrigé).

Les hélicos????
Ca m'étonnerait. Ce n'est pas au point du tout, et ça ne semble pas être une priorité depuis au moins la 3.5, rien n'a changé.
Avatar de l’utilisateur

jeanba
As du Manche
As du Manche
Messages : 11110
Inscription : 17 septembre 2001

Re: B.A.T. (ex C.U.P.) Battlefield-Airborne-Tactical

#63

Message par jeanba » mar. août 20, 2019 4:42 pm

Questions campagnes, je fais très attention à ne prendre que des campagnes faites spécifiquement pour CUP
Avatar de l’utilisateur

Gaston
Chef de patrouille
Chef de patrouille
Messages : 5714
Inscription : 13 janvier 2003

Re: B.A.T. (ex C.U.P.) Battlefield-Airborne-Tactical

#64

Message par Gaston » mar. août 20, 2019 7:14 pm

jeanba a écrit :
mar. août 20, 2019 11:13 am

Tu as un "community pack" dispo ici:
https://www.sas1946.com/main/index.php/ ... 119.0.html
J'y ai même retrouvé les missions de ma bonne vieille campagne Helvète, tiens...
Avatar de l’utilisateur

Bed
Nouvelle Recrue
Nouvelle Recrue
Messages : 91
Inscription : 01 septembre 2004

Re: B.A.T. (ex C.U.P.) Battlefield-Airborne-Tactical

#65

Message par Bed » mar. août 20, 2019 8:51 pm

Je viens de tout installer ! 3.7 + les packs Missions et DGEN compatible !!
Sacré boulot !!! :emlaugh:

C'est énorme quand même.
Je n'ai testé que WAW avec une mission (F8F indochine) et un DGEN (109 E7) ! quel bonheur !! (et avec des IA correctes et des commandes adaptées) :cheer:

Bref, j'suis content ! :banana:

En dehors du graphique qui date un peu (qu'on oublie franchement une fois immergé et dans l'action), c'est du bon !
Avatar de l’utilisateur

50H-Solo
Jeune Pilote
Jeune Pilote
Messages : 1853
Inscription : 14 avril 2003

Re: B.A.T. (ex C.U.P.) Battlefield-Airborne-Tactical

#66

Message par 50H-Solo » dim. avr. 19, 2020 3:17 pm

Petit déterrage de topic.
J'ai profité du confinement pour télécharger et installer BAT, vu la sortie du patch 3.8.3. Je ne connaissait pas donc allez on installe pour voir.
Déjà, mon antivirus ne faisait pas bon ménage avec les installeurs mais bon, c'est pas la première fois que ça m'arrive.
Pour les 3 premières périodes, tout à l'air de fonctionner, sauf le Piper CUB qui est vérolé sur la période n°3 (et l'hélice du Stearman qui tourne à l'envers du pas :Jumpy: , mais je pense qu'il doit y avoir d'autres avions avec ce pb, j'ai pas tout regardé).
J'ai pas mal ramé pour pouvoir faire fonctionner la période "JTW". Le simu se chargeait mais une fois le multijoueur créé et la base choisie sur la carte, la liste des avions n'apparaissait pas en cliquant sur le bouton qui va bien. Après pas mal de tests et de bidouilles, je me suis aperçu qu'il y avait pas mal de pb avec cette période. C'est le PA18 (qui est aussi vérolé dans cette période) qui est en tête de liste du fichier air.ini qui fout la zone, . Donc remplacement de la première ligne du air.ini par une copie de la 2ème (un Canberra) et j'ai enfin pu voir s'afficher la liste de choix des taxis. Beaucoup de zincs sont foireux. Entre ceux ou aucun visuel ne s'affiche, ceux qui sont tout roses, ceux ou la skin d'origine n'est pas adaptée (le Cruze par exemple) et les Canberra ou la fumée au démarrage est devant les turbines (normal ??) et s'échappe à la verticale, y'a du boulot de mise au point à faire je trouve.
Je ne sais pas si c'est propre à mon install ou si c'est pour tout le monde pareil, en tout cas c'est pas la période la plus sympa. Pourtant j'aime bien les taxis des 50's et 60's.

Poursuite des tests:
D'après le log, le pb des avions roses viendrait d'une incohérence de taille de texture. La texture avion (taille des fichiers TGA je présume) étant plus grosse que la taille allouée au buffer, elle ne se charge pas. Du coup, je ne pense pas que ça soit mon install qui foire.
Je ne sais pas s'il est possible de modifier la taille du buffer mais pour les textures c'est mort, tout est dans les fichiers SFS.
Avatar de l’utilisateur

CdtLapin
Nouvelle Recrue
Nouvelle Recrue
Messages : 85
Inscription : 28 mars 2019

Re: B.A.T. (ex C.U.P.) Battlefield-Airborne-Tactical

#67

Message par CdtLapin » lun. mai 04, 2020 1:18 am

1) Etant donné le grand nombre d'avions et que BAT est une gigantesque compilation/harmonisation de mods plus ou moins disparates, il est inévitable que certains avions buggent (sur certaines cartes par exemple). Je ne peux t'en dire plus car je suis loin de les avoir tous essayés. Dans mon installation il y a des bugs toujours les mêmes (sur les ntracks) qui ne sont pas corrigés au moins depuis la 3.5. Les auteurs préfèrent ajouter des avions qui n'ont jamais volé, dans l'esprit de "1946" au lieu de fignoler l'équilibre et les incompatibilités des mods.
Quitte à supprimer les plus intéressants comme l'UV3 (compatible avec la 412.2 De BAT et le visual pal mod 08 (qui ne fait rien bugguer dans mon installation).
C'est bien dommage, mais les avantages l'emportent sur les inconvénients.
Le "nouveau" viseur du Spad XIII est toujours inutilisable.
Mais ce que tu décris est d'un autre ordre. Tu devrais bien lire les conseils d'installation de BAT pour la première installation puis des versions/mises à jour suivantes par dessus puis les patches pour quelques unes d'entre elles. Peut-être vaut-il mieux tout réinstaller, malgré l'énorme travail que ça demande.

2) Ce que tu dis du fichier air.ini est par contre complètement anormal. Tu as du faire une erreur quelque part. Ou alors tu joues avec des "pilotes" qui n'ont pas la même version de BAT.

3) Pour les avions roses, il faut télécharger et installer (coller dans le dossier racine en écrasant les anciennes) des DLLs "alternatives" (va voir dans les BAT downloads et les ipremiers messages qui suivent les consignes d'installation, tu trouveras les liens) En général les problèmes viennent d'une absence de lecture des de ces consignes.
Avatar de l’utilisateur

50H-Solo
Jeune Pilote
Jeune Pilote
Messages : 1853
Inscription : 14 avril 2003

Re: B.A.T. (ex C.U.P.) Battlefield-Airborne-Tactical

#68

Message par 50H-Solo » dim. mai 24, 2020 10:54 am

Hello CdtLapin.
Désolé de ne pas être repassé dans cette salle depuis un bout de temps, mais comme j'ai repris le boulot début mai, j'ai un peu laché l'affaire de BAT pour le moment.
L'installation, j'ai du la refaire 3 ou 4 fois, en suivant rigoureusement la procédure et en mettant les patches (en version exe, donc pas de bidouille) dans l'ordre, et en désactivant l'antivirus qui me sortait du faux positif (et m'a planté ma première install) pour les 4 ou 5 derniers update.
Comme j'avais de la place sur mes disques, les tests ont été faits en alternant les installations une fois à partir de la 4.09m stock puis en installant tous les patches succesifs jusqu'à la 4.12.2m et la fois suivante en installant le megapatch de SAS sur une 4.09m stock.
J'ai même fait le téléchargement de toutes les versions de B.A.T 2 fois, bonjour le temps de chargement avec mon Adsl à 10Mo.
A chaque install (je confirme que 95 Go d'installation, ça prend du temps, vive le confinement :Jumpy: :Jumpy:) j'ai eu le même résultat.

Le pb n'apparaissait pas avec les premiers updates en plus (je testais à chaque nouvel update pour vérifier). Jusqu'à la V3.2 ou 3.3 (je ne sais plus), je n'avais pas de problème, c'est ensuite que ça à commencer à foirer (d'où le re-téléchargement du tout). Comme la seule période qui me faisait des misères était l'après 1946, si mon install était vérolée, j'aurais eu d'autres pb sur les premières périodes.

A la dernière tentative (j'ai failli par tout virer du disque et abandonner ce truc mais c'est pas le genre de la maison :hum: :cheer:), j'ai pris le taureau par les cornes et j'ai mis les mains dans le cambouis (plus de 15 ans que j'avais lâché ce simu, donc j'avais oublié pas mal de choses sur son fonctionnement mais bon, les souvenirs se réveillent) pour regarder ce qui pouvait foirer (réactivation des logs, ouverture des fichiers ini, etc....).

Je prends note pour les Dll alternatives, je les avais récupérées mais pas installées vu que je n'avais pas bien compris à quoi elle pouvaient servir, je testerais.
Dans le air.ini, j'ai désactivé tout ce qui posait pb (après avoir fait une copie du fichier d'origine), je réactiverais les zincs un à un avec les dll alternatives pour voir si ça règle le pb des taxis roses fluo.

J'ai tout essayé en OffLine et sur les cartes d'origine d'IL2, donc en solo et sans rien d'exotique, histoire de pas polluer les tests.

Merci pour ton aide.
Avatar de l’utilisateur

CdtLapin
Nouvelle Recrue
Nouvelle Recrue
Messages : 85
Inscription : 28 mars 2019

Re: B.A.T. (ex C.U.P.) Battlefield-Airborne-Tactical

#69

Message par CdtLapin » lun. mai 25, 2020 12:07 am

Hello 50h-Solo,
1) Garde tes téléchargements (mises à jour-étapes et patches). Il n'y a aucune raison qu'il y ait un problème avec eux. L'important est de les avoir tous, bien rangés dans un dossier portant le nom de la version de étape de BAT : par exemple Line Baker ou Checkpoint Charlie) regroupant l'exécutable installateur et ses fichiers d'installation, plus pour certaines, les patches ou les DLL à installer aussitôt après.
Il faut bien sûr les installer dans l'ordre chronologique ou numérique.

2) Si tu arrives à un fonctionnement normal jusqu'à la 3.2 ou la 3.3 , fais une copie de son dossier racine. Tu pourras faire d'autres tentatives moins coûteuses en temps.

3) Tu n'avais aucune chance de réussir sur une 4.09. BAT s'installe exclusivement sur une 4.12.2 initiale.

4) Je ne sais pas si tu le fais, sans doute que oui, mais on ne sait jamais. Pour passer de la WW2 (WaW) à JTW par exemple, est ce que tu passes bien les étapes suivantes:

-utiliser jgsme.exe pour désactiver tous les mods WaW, (fenêtre droite VIDE)

-puis activer les mods JtW. (en les faisant passer de la fenêtre de gauche vers la fenêtre de droite).

-lancer IL2 selector, puis sélectionner JtW (memory settings).

-lancer BAT "Start IL2 now) (avec IL 2 SELECTOR la première fois) .
Illustration (pour lancer BAT WaW)

Image

Image


Image





-la procédure est la même pour changer de module (passer de JtW à DoF par exemple).

Si tu fais tout ça, alors tes difficultés sont pour moi inexplicables. Sauf bien sûr, celles que tous les utilisateurs de BAT connaissent.
Bonne chance et tiens nous au courant. La 3.8.2 vaut la peine.
Avatar de l’utilisateur

50H-Solo
Jeune Pilote
Jeune Pilote
Messages : 1853
Inscription : 14 avril 2003

Re: B.A.T. (ex C.U.P.) Battlefield-Airborne-Tactical

#70

Message par 50H-Solo » lun. mai 25, 2020 11:53 am

Je suis toujours parti d'une 4.12.2m pour installer B.A.T. une première fois mettant le megapatch sur une 4.09m stock et une deuxieme fois en mettant tous les patches officiels succesifs toujours sur cette même 4.09m.

Bon, RTT fixe aujourd'hui, donc j'ai remis les mains dans B.A.T.
J'ai commencé par le pb de textures.
Premier essai avec le jeu de DLL 01- même pb d'avions roses et de skins dans le mauvais sens pour quelques taxis.
Deuxième essais avec le jeu de DLL 02 - Yeepee, plus de bug de textures ni d'avions roses.

J'ai vidé une nouvelle fois les mods JSGME, repassé le jeu en stock depuis le selector, remis le air.ini d'origine en place, les mods qui vont bien depuis jgsme et réactivé la période JTW depuis le selector.
J'avais toujours le pb de menu vide si je laisse le PA18 en 1ère ligne du air.ini.
Re vidage et retour en stock avec le selector.
Je me suis donc focalisé sur les mods JGSME du J3 cub pour la période JTW (c'était le plus simple, et au pire je pouvais toujours me passer de ce tagazou avec mon air.ini modifié).
J'ai recherché ou ils étaient planqués dans les fichiers compressés et j'ai forcé l'expansion des 2 répertoires depuis WinRar. J'ai remplacé ceux de mon install par ces 2 là.
J'ai tout bien réactivé dans l'ordre et miracle, plus de pb. Tout ça pour une décompression foireuse. arrrgghhh !!!! :Jumpy: :busted_re :hum:

Comme je fais souvent plusieurs choses en même temps, parfois ça foire.
J'ai pas tout testé, mais je dois avoir une installation correcte, y'a plus qu'à sauvegarder ça dans un coin au cas ou.
Ça aura été laborieux, mais j'en ai vu le bout, de cette installation.

Merci pour le coup de main, tes explications m'ont bien aidé à trouver où se cachait le loup.

Reste plus plus qu'a regarder les modifs à faire au conf.ini et configurer les commandes, mais ça, c'est pas pour tout de suite.
Je suis en train de refaire complètement mes consoles, donc du boulot pour cet hiver.
Avatar de l’utilisateur

CdtLapin
Nouvelle Recrue
Nouvelle Recrue
Messages : 85
Inscription : 28 mars 2019

Re: B.A.T. (ex C.U.P.) Battlefield-Airborne-Tactical

#71

Message par CdtLapin » mar. mai 26, 2020 12:08 am

Hello,
Le mégapatch pour passer en 4.12.2 s'applique sur une 4.07m pas sur une 4.09m!!!!
De là viennent peut-être tes difficultés (je dis peut-être car je n'ai jamais tenté une installation de la 4.12.2 sur une 4.09).

Il y a bien le Piper Cub en tête mais ça marche dans mon installation.
Tous les avios sont dans le menu déroulant en-dessous.
Qu'as tu fait exactement avec ton air.ini, et d'ailleurs lequel?
Il y en a cinq dans le dossier racine de BAT.

Regarde dans les dossiers #SAS, #DOF3, #TGA3# , WAW3,# JTW3 dans chacun, il y a un dossier STD qui contient dans le dossier com (sauf pour #SAS) un fichier air.ini pour les avions du module.
Il n'y a à toucher à ces fichiers (air.ini) que si l'on veut ajouter un avion ou en désactiver un (en mettant // devant l'entrée).
Tu n'es pas obligé de retirer l'entrée si tu veux te débarrasser d'un avion.

Je ne comprends pas ce que tu racontes concernant les mods du dossier jsgmemods: il y a deux mods dédiés au Piper cub de JTW mais ils sont incompatibles entre eux (version avec roues, version hydravion) tu ne peux qu'en activer un à la fois.
Par défaut choisis #JTW_ALT-J3CUB TUNDRA, l'autre est un hydravion et il est en effet buggé.
Avatar de l’utilisateur

50H-Solo
Jeune Pilote
Jeune Pilote
Messages : 1853
Inscription : 14 avril 2003

Re: B.A.T. (ex C.U.P.) Battlefield-Airborne-Tactical

#72

Message par 50H-Solo » mar. mai 26, 2020 4:45 pm

De ce que j'avais compris, il fallait que j'active TOUS les mods JTW du répertoire JSGME. :hum: :Jumpy: :Jumpy:
Le air.ini, je n'ai modifié que celui de la période JTW, les autres ne posaient pas problème j'avais juste remplacé la première ligne (le cub) par un autre taxi (un des Panther) et collé des // (ou \\) devant tous les taxis roses.
Bon, c'est pas grave, je vais virer l'hydravion mais je n'ai plus de pb depuis que j'ai re-décompressé les 2 mods du Cub. Je peux laisser le air.ini d'origine sans que je me retrouves avec une liste d'avions vide.
Pour le Mégapatch, si tu le mets sur une 4.09m au lieu d'une 4.07m, au pire ça va remettre des trucs qui y sont déjà, normalement ça met pas la zone.
En tout cas, tes explications ont bien fonctionné, tout fonctionne normalement maintenant.
Sur certains taxis, je ne peux pas changer de skin, mais bon, c'est pas un soucis, surement des skins pas compatibles avec BAT, faut que je fasse du tri.
Déjà, je vais bricoler mon petit fichier batch qui crée les dossiers manquants pour qu'il fonctionne avec B.A.T.
Merci encore pour le coup de main.
Avatar de l’utilisateur

CdtLapin
Nouvelle Recrue
Nouvelle Recrue
Messages : 85
Inscription : 28 mars 2019

Re: B.A.T. (ex C.U.P.) Battlefield-Airborne-Tactical

#73

Message par CdtLapin » mar. mai 26, 2020 5:22 pm

Heureux de voir que ça marche mieux.
Tu PEUX activer TOUS les mods de JtW ou une partie seulement pour jouer JtW.
Mais SEULS des mods JtW doivent être activés.

Tu peux laisser le Cub hydravion dans le air ini.
Ca ne changera rien.
Selon celui que tu actives (le Tundra) avec jgsme.exe, l'autre n'est pas chargé et n'apparaît pas dans le menu du QMB.
Normalement si tu tentes d'activer un deuxième mod de Cub, après avoir activé l'autre, tu as un message d'erreur.
Si tu passes outre , il n'est pas surprenant qu'il y ait des bugs ensuite.

Pour les skins, c'est simple.
Tu dois nommer ton dossier qui les contient EXACTEMENT comme dans l'entrée de l'avion dans ton air.ini
Exemple d'entrée
F-86D45 air.F_86D45 1 NOINFO usa01 SUMMER
Le nom du dossier DOIT être F-86D45.
Une SEULE erreur et le jeu ne trouve pas tes skins: c'est normal.
Si tu écris F_86D45 , par exemple, c'est cuit! :crying:
Attention aux surprises pour certains avions "stocks" (comme les A6M "Zéros"/Zeke ou les Spitfires) mais aussi pour des avions créés depuis ((MB 174, CR 714, RE 2005 et j'en passe).
Il y a de nouveaux modèles en 3D qui ne s'habillent pas du tout de la même façon avec les skins .
Compare les (tu verras sur l'image bmp que l'agencement des parties de l'avion est différent).
Tu auras donc peut-être la mauvaise surprise de trouver des avions avec une peinture aberrante.
C'est normal.
Il faut juste trier et archiver le classement.
Certains skins "vont avec" l'avion de ton jeu, d'autres correspondent à une autre version en 3D du même avion
Si utilises d'autres "mods" que BAT, certains des vieux skins serviront peut-être.
Perso, j'ai seulement viré ceux qui étaient en 512 x 512.
Pas assez "définis" pour les écrans de maintenant.
1024 x 1024 est le minimum.
Mais BAT accepte d'emblée des skins HD (2028 x 2028, 4096 x 4096 EN 24 BITS et non plus seulement 8 bits: 256 couleurs).
Tes anciens skins serviront peu pour les A6M: tous les A6M de BAT sont des nouveaux modèles en 3D.
Avatar de l’utilisateur

50H-Solo
Jeune Pilote
Jeune Pilote
Messages : 1853
Inscription : 14 avril 2003

Re: B.A.T. (ex C.U.P.) Battlefield-Airborne-Tactical

#74

Message par 50H-Solo » mar. mai 26, 2020 5:56 pm

Oui, je sais bien comment marchent les dossiers de skins.
Pour éviter aux joueurs de se prendre la tête (ouvrir le air.ini, noter le nom exact du taxi, créer le dossier au bon endroit, etc...) nous avions créé (il y a presque 10 ans), avec BlackStaff/Epervier, un petit fichier batch qui "lit" les fichiers air.ini et crée les répertoires manquants. Ceci pour les packs de mods les plus en vogue à l'époque. On avait même, passé un moment, fait évoluer ce truc pour qu'il vire les dossiers erronés et qu'il sauvegarde sur un autre disque les dossiers qui ne servent pas au mods activés. Bon cette dernière partie, c'était utile quand les disques durs n'étaient pas suffisamment gros et qu'il fallait de la place pour autre chose. Maintenant, on peut laisser les dossiers en place vu la taille des stockages. J'ai modifié le pgm pour l'adapter à l'IES 3.5, je vais voir pour en faire autant pour BAT.
Dans BAT, j'ai rajouté des skins pour le Cruze, (qui sortent d'où, je ne sais plus) elles apparaissent bien dans la liste mais il semblerait que le simu n'en tienne jamais compte, le taxi garde toujours sa livrée d'origine. Ce sera mon prochain challenge, mettre de l'ordre dans mes fichiers de skins.
Avatar de l’utilisateur

CdtLapin
Nouvelle Recrue
Nouvelle Recrue
Messages : 85
Inscription : 28 mars 2019

Re: B.A.T. (ex C.U.P.) Battlefield-Airborne-Tactical

#75

Message par CdtLapin » mar. mai 26, 2020 8:01 pm

OK!
A moi ce petit fichier Batch serait bien utile.
Dans mon SAS ModAct 5.30, je dois avoir pas loin de 50 modèles de Spitfires avec des noms complexes et longs.
Répondre

Revenir à « Salle "MODS" IL2-1946 »